Joomla!: PHP-Version erfolgreich aktualisieren

Für Webhosting

Hier erfahren Sie, wie Sie die PHP-Version, auf der Ihre Joomla!-Website läuft, ändern können und was Sie beim Wechsel zu einer neueren PHP-Version beachten müssen.

Was ist PHP?

PHP ist eine Programmiersprache, die auf dem Webserver läuft.  PHP wird hauptsächlich zur Erstellung dynamischer Webseiten oder Webanwendungen verwendet. Beispielsweise laufen alle Joomla!-Websites auf PHP.

Wann ist ein Versionswechsel sinnvoll?

Wie Joomla! wird auch PHP ständig weiterentwickelt und verbessert. Für Betreiber einer Joomla!-Website kann daher eine der folgenden Situationen eintreten, die einen Wechsel der PHP-Version erforderlich machen:

  • Ein Joomla!-Update erfordert eine neuere Version von PHP.
  • Eine bestimmte Version von PHP ist veraltet und sollte daher nicht mehr verwendet werden.
  • Eine neue PHP-Version ist verfügbar und enthält Leistungssteigerungen, von denen Sie profitieren möchten.

Welche Version sollte verwendet werden?

Bei IONOS können Sie zwischen verschiedenen PHP-Version wählen. Wenn kein besonderer Grund für eine bestimmte Version vorliegt, sollten Sie in Ihrer PHP-Verwaltung empfohlene Version verwenden. Derzeit ist dies PHP 7.3. Mit dieser Version können Sie die bekanntesten und bewährtesten Applikationen ohne weitere Kompatibilitätsprobleme nutzen.

Wechsel der PHP-Version vorbereiten und durchführen

Technisch gesehen benötigen Sie nur wenige Mausklicks, um Ihre Domain - und damit Ihre Website - auf eine neue PHP-Version umzustellen. Es kann jedoch sein, dass die verwendete Joomla!-Version, einzelne Plugins oder das Theme noch nicht vollständig mit der neuen PHP-Version kompatibel sind. Um daraus resultierende Fehlfunktionen zu vermeiden, ist es daher ratsam, die Website auf den Wechsel der PHP-Version vorzubereiten und dann die PHP-Version umzustellen. Wir empfehlen die folgende Vorgehensweise beim Wechsel auf eine neue PHP-Version:

    • Backup erstellen

      Bevor Sie die PHP-Version umstellen, sollten Sie ein Backup Ihrer Joomla!-Website anlegen. Wenn Sie noch keine eigene Backup-Strategie haben, empfehlen wir Ihnen das kostenlose Akeeba Backup Plugin. Akeeba Backup ist eine einfach zu bedienende Open-Source-Backup-Lösung, mit der Sie ein vollständiges Backup Ihrer Website erstellen können.

    • Joomla!-Installation aktualisieren

      Je älter Ihre Joomla!-Version ist, desto wahrscheinlicher ist es, dass der verwendete PHP-Programmcode nicht mehr mit der neuen PHP-Version kompatibel ist. Bitte prüfen Sie, ob Updates für Ihre Joomla!-Version, Plugins und das Theme verfügbar sind. Sofern Sie nicht aus bestimmten Gründen eine ältere Version verwenden müssen, sollten Sie Ihre Joomla!-Installation und alle Komponenten immer auf dem neuesten Stand halten. Denn diese Updates schließen auch regelmäßig Sicherheitslücken.

    • Kompatibilität des Themes und der Plugins prüfen

      Wenn Sie Plugins von Drittanbietern verwenden, wie z.B. ein Fotoalbum, können Sie im Voraus überprüfen, ob es mit der zukünftigen PHP-Version kompatibel ist. 
      Öffnen Sie die Seite https://extensions.joomla.org/  und suchen Sie nach den entsprechenden Plugins.  Auf der jeweiligen Seite klicken Sie auf die Schaltfläche Support. Durchsuchen Sie den Seiteninhalt nach Hinweisen zur PHP-Version. Ggf. verbirgt sich diese Information auch unter einem weiteren Link  „Requirements“,
    • PHP-Version umstellen

      Nachdem Sie alle Vorbereitungen getroffen haben, können Sie Ihre Domain auf die gewünschte PHP-Version umstellen. Das Aktivieren der neuen PHP-Version dauert nur wenige Minuten.  So ändern  Sie die PHP-Version für Ihre Domain
    • Website auf Fehler prüfen

      Sobald die neue PHP-Version aktiv ist, sollten Sie die Website sofort auf Herz und Nieren prüfen:
      - Ist die Website erreichbar?
      - Sind alle Unterseiten erreichbar?
      - Funktionieren alle Slider, Galerien, Formulare etc.?
      - Funktioniert das Backend (Administrationsbereich)?

    Anmerkungen

    Kommt es mit der neuen PHP-Version zu Problemen, empfiehlt es sich, alle Plugins nochmals auf Aktualität und Kompatibilität zu überprüfen. Möglicherweise müssen Sie inkompatible Plugins deinstallieren oder durch andere Plugins ersetzen.

    Um im Problemfall schnellstmöglich wieder die Erreichbarkeit der Website - oder des Backends - herzustellen, können Sie die Domain wieder auf die vorherige PHP-Version umstellen. Beachten Sie, dass es nach der Umstellung wieder ein paar Minuten dauern kann, bis diese PHP-Version aktiv ist. Sollten nun auch mit der alten Version Fehler auftreten, müssen Sie Ihre Website aus dem Backup wiederherstellen.