Excel: Was kann SUMMENPRODUKT? Die Funktion erklärt!

Zugegeben, der Name ist etwas irreführend. Die Funktion erzeugt nicht, wie man leicht denken könnte, das Produkt (also das Ergebnis einer Multiplikation) mehrerer Summen (Ergebnis einer Addition). Stattdessen sorgt die Funktion für den umgekehrten Fall: Mehrere Produkte werden zu einer Summe zusammengerechnet. In Excel hilft SUMMENPRODUKT sowohl bei kleinen Tabellen als auch bei einer großen Matrix.

Wobei hilft die Funktion SUMMENPRODUKT?

Immer dann, wenn Sie in Excel zuerst mehrere Werte miteinander multiplizieren und diese Ergebnisse dann zusammenrechnenwollen, kann Ihnen die Funktion SUMMENPRODUKT helfen. Wenn man beispielsweise mehrere Matrizen in seinem Arbeitsblatt untergebracht hat, und diese miteinander verrechnen möchte, geht das mit SUMMENPRODUKT sehr einfach. Gehen wir von einer zweispaltigen Tabelle aus: Mit SUMMENPRODUKT können Sie die beiden Werte jeder Zeile miteinander multiplizieren und dann alle Ergebnisse zu einer Summe addieren.

SUMMENPRODUKT ist eine Matrixformel. Wenn Sie eine Funktion als Matrixformel verwenden möchten, erfolgt die Bestätigung der Formeleingabe normalerweise mit der Tastenkombination [Strg] + [Umschalt] + [Enter]. Bei SUMMENPRODUKT ist dies nicht notwendig. Die Funktion an sich ist bereits auf die Verarbeitung von Matrizen angelegt. Excel benötigt deshalb kein spezielles Signal.

Syntax von Excel-SUMMENPRODUKT

Die Excel-Funktion SUMMENPRODUKT hat eine relativ einfache Struktur. In ihr werden in der Regel nur die Bereiche angegeben, die in die Berechnung mit aufgenommen werden sollen.

=SUMMENPRODUKT(Matrix1;[Matrix2];[array3]…)

In der Formel muss also mindestens eine Matrix genannt werden. Sie können allerdings bis zu 256 Einträge vornehmen. Excel gibt Ihnen verschiedenen Möglichkeiten, um die Parameter zu füllen. Sie können die Matrix per Zellbezug eingeben, mit einem Namen auf den gewünschten Bereich verweisen oder direkt ein Array (also eine Sammlung von Werten) in die Formel eintragen.

  • Zellbereich: =SUMMENPRODUKT(A2:A6;B2:B6)
  • Name: =SUMMENPRODUKT(Matrix1;Matrix2)
  • Array: =SUMMENPRODUKT({15;27;12;16;22};{2;5;1;2;3})
Hinweis

Damit Sie Namen innerhalb der Funktion verwenden können, müssen Sie diese zunächst definieren. Markieren Sie dazu den entsprechenden Bereich inklusive einer Kopfzeile, in welchen Sie den Namen bereits eingetragen haben, und gehen Sie dann auf „Formeln und „Aus Auswahl erstellen“.

Die entsprechenden Zellbereiche müssen immer symmetrisch sein: Enthält die zweite Matrix beispielsweise eine Zeile bzw. einen Wert weniger als der erste Bereich, kommt es zu einer Fehlermeldung.

SUMMENPRODUKT-Funktion in der Praxis

Die Funktion SUMMENPRODUKT bringt einige Vorteile mit sich: Der offensichtlichste Vorteil ist, dass Sie sich durch die Verknüpfung von Multiplikation und Addition mehrere Rechenschritte sparen können. Zudem lässt sich die SUMMENPRODUKT sehr gut mit anderen Funktionen verknüpfen. Die Funktion ermöglicht aber auch noch Kniffe, die interessant für komplexere Aufgaben sind.

SUMMENPRODUKT mit Vergleich

So hat SUMMENPRODUKT beispielsweise einen eingebauten Aspekt, der der Funktion SUMMEWENN gleicht. So können Sie auswählen, welche Werte innerhalb der Matrizen in die Berechnung aufgenommen werden sollen. Hierfür müssen Sie lediglich die eigentliche Syntax der Funktion etwas abwandeln:

=SUMMENPRODUKT((A2:A11=A14)*B2:B11*C2:C11)

In das erste Argument haben wir also einen Vergleich eingefügt. Nur wenn die Angaben dem Wert in Zelle A14 entsprechen, werden die zugehörigen Zellen miteinander multipliziert und in die Summe aufgenommen. Neben dem Gleichheitszeichen, das den Vergleich durchführt, sind Multiplikationszeichen hinzugekommen. In der normalen Syntax können die Bereiche einfach mit einem Semikolon abgetrennt werden. Excel versteht üblicherweise auch so, wie es mit den Angaben umzugehen hat. Wenn Sie allerdings den Vergleich einbauen, fordert die Funktion die klare Auszeichnung der Rechenoperation. Sonst kommt es zu einem Fehler.

Weitere Multiplikationsmöglichkeiten

Mithilfe des Sternchens können Sie die Multiplikation auch anders durchführen. Wie bereits erwähnt, funktioniert die Funktion eigentlich nur, wenn die angegebenen Bereiche die gleiche Anzahl von Zellen haben. Nun kann es aber vorkommen, dass immer mit demselben Wert multipliziert werden soll. Theoretisch müssten Sie hierfür eine Matrix verwenden, in der in jeder Zelle der gleiche Wert auftaucht. Stattdessen können Sie den Wert aber auch nur einmal in einer Zelle hinterlegen und dann die Schreibweise mit „*“ verwenden.

=SUMMENPRODUKT(A1:A10*$B$1)

Nehmen wir als weiteres Beispiel den Fall an, dass man verschiedene Zellen addieren möchte und diese dann wiederum mit einem Wert multiplizieren und anschließend die Ergebnisse dann erneut summiert möchte. Um das mit Excel umzusetzen, gibt es zwei verschiedene Möglichkeiten:

=SUMMENPRODUKT(A2:C6*D2:D6)

Auch hier nutzen Sie wieder das Mal-Zeichen. Die Werte im großen Bereich werden zunächst untereinander addiert und dann mit dem zweiten Bereich multipliziert.

=SUMMENPRODUKT((A2:A6+B2:B6+C2:C6);D2:D6)

In dieser Formel kann man dann wieder das Semikolon nutzen. Dafür muss man Excel allerdings explizit mitteilen, dass die einzelnen Bereiche erst addiert werden sollen.

SUMMENPRODUKT mit weiteren Funktionen kombinieren

Die SUMMENPRODUKT-Funktion lässt sich selbstverständlich auch mit anderen Excel-Funktionen kombinieren. So kann man mehrere Schritte in einer Formel unterbringen und muss nicht mit Hilfszellen arbeiten, um Zwischenergebnisse abzulegen. Folgendermaßen können Sie das Ergebnis der Funktion beispielsweise direkt abrunden lassen:

=ABRUNDEN(SUMMENPRODUKT(A2:A6;B2:B6);-1)

SUMMENPRODUKT ist bei diesem Beispiel in die ABRUNDEN-Funktion integriert und dient dort als erster Parameter.

Fazit

In Excel bietet Ihnen SUMMENPRODUKT zahlreiche Möglichkeiten, komplexe Berechnungen zu vereinfachen. Die Funktion können Sie entweder für sich allein nutzen oder mit anderen Funktionen kombinieren.


Auf dem Laufenden bleiben?

Jetzt für unseren Newsletter anmelden und gratis Online-Marketing Whitepaper für lokale Anbieter sichern!