WENN-Funktion in Excel einfach erklärt

Die WENN-DANN-Funktion ist eine der ältesten und beliebtesten Excel-Funktionen. Das Prinzip ist sehr simpel: Wenn ein Wert wahr ist, dann mach das eine, sonst mach das andere. Wir erklären Ihnen, wie die WENN-DANN-Funktion richtig eingesetzt wird und wofür man sie braucht.

Was ist die WENN-DANN-Funktion?

Mit der WENN-Funktion (so heißt die Formel korrekt) können Sie einen logischen Vergleich anstellen: Ist der abgefragte Wert mit dem erwarteten identisch oder nicht? Nur wenn diese Abfrage wahr ist, soll ein bestimmter Fall eintreten. Ist der Vergleich falsch, löst dies eine andere Aktion aus – also: wenn A, dann B, sonst C.

Damit gehört WENN-DANN in Excel zu den wichtigsten Hilfsmitteln. Die Funktion kann in allen möglichen Situationen zum Einsatz kommen: Egal, ob Sie mit einem einfachen Mitgliederverzeichnis, einem Tabellenblatt zu Unternehmenskennzahlen oder statistischen Auswertungen arbeiten – WENN wird Ihnen allein oder in Kombination mit anderen Funktionen eine große Hilfe sein.

Tipp

Mit dem IONOS HiDrive Cloud-Speicher speichern, bearbeiten und teilen Sie Ihre Office-Dokumente zentral und sicher. Ob privat oder beruflich: Arbeiten Sie flexibel von jedem Gerät aus mit der HiDrive-App und anderen Schnittstellen. In den hochmodernen deutschen Rechenzentren von IONOS sind Ihre Daten bestens geschützt.

Excel mit Microsoft 365 Business von IONOS!

Organisieren Sie Ihre Daten in Excel und erstellen Sie im Handumdrehen Tabellen. In allen Office-Paketen enthalten!

Office Online
OneDrive mit 1TB
24/7 Support
Hinweis

Die nachfolgenden Anleitungen gelten sowohl für die Excel-Version von Microsoft 365 als auch für die Excel-Versionen 2021, 2019 und 2016!

Wie funktioniert die Excel-WENN-DANN-Funktion?

Jeder Funktion in Excel liegt eine bestimmte Syntax zugrunde, so auch im Falle von WENN:

=WENN(Prüfung;Dann_Wert;Sonst_Wert)

Die Funktion beinhaltet demnach drei Parameter, von denen Sie die ersten beiden verpflichtend ausfüllen müssen.

  • Prüfung: An dieser Stelle muss eine Bedingung stehen, ein Vergleich zwischen zwei Werten, wobei einer oder beide in Form von Referenzen auf Zellen vorliegen können. Mögliche Bedingungen lauten:
    • Gleich =
    • Ungleich <>
    • Kleiner als <
    • Größer als >
    • Kleiner als oder gleich <=
    • Größer als oder gleich >=
  • Dann_Wert: In diesen Parameter tragen Sie ein, was passieren soll, wenn die abgeprüfte Bedingung wahr ist. Als Ergebnisse können Werte, Zeichenketten, Zellbezüge oder auch andere Funktionen dienen. Sie müssen Zeichenketten in Anführungszeichen setzen.
  • Sonst_Wert: Der letzte Parameter ist optional. Wenn Sie an dieser Stelle nichts angeben, wird die Funktion FALSCH ausgeben. Ansonsten verhält sich Sonst_Wert analog zum Dann_Wert.

In der Praxis könnte eine WENN-DANN-Funktion in Excel also so aussehen:

=WENN(A1>=100;"Ziel erreicht";"Ziel noch nicht erreicht")

Tipp

In Excel werden Funktionen in der Bearbeitungszeile immer mit einem Gleichheitszeichen eingeleitet und Parameter in eine Klammer eingebettet. Wenn Sie Zellbezüge verwenden, können Sie diese mit einem Dollarzeichen absolut machen. Das bedeutet, dass Funktionen auch beim Kopieren in andere Zellen den Bezug auf die ursprüngliche Zelle behalten.

Wenn Sie möchten, müssen Sie die Wenn-Funktion auch nicht per Hand in die Bearbeitungszeile eintragen. Mit „Funktion einfügen“ bietet Ihnen Excel eine Hilfe beim korrekten Ausfüllen von Formeln.

Die WENN-DANN-Funktion an einigen Beispielen erklärt

Die WENN-DANN-Funktion findet in den verschiedensten Situationen Anwendung, sowohl bei einfachen als auch bei sehr komplexen Tabellenkalkulationen. Wir veranschaulichen die Funktionsweise und Einsatzmöglichkeiten der Funktion anhand von fünf kurzen Beispielen.

Sortierung von Datenpunkten

Wollen Sie eine Reihe von Datenpunkten basierend auf einem Kriterium in zwei Gruppen aufteilen, können Sie dies mit der Excel-WENN-Funktion tun. Beispielsweise könnten Sie überprüfen, ob jemand eine Prüfung bestanden hat oder nicht. In folgendem Beispiel ist die Prüfung mit 50 Prozent der Punkte bestanden.

=WENN(B2 >= 50%; "Bestanden"; "Durchgefallen")
Sie können WENN-DANN benutzen, um Werte basierend auf einer Bedingung in zwei Gruppen aufzuteilen.

Überprüfung textueller Werte

Die WENN-Funktion kann nicht nur zur Überprüfung numerischer, sondern auch zur Überprüfung textueller Werte eingesetzt werden. In folgendem Beispiel wird überprüft, ob ein Buch von dem Autor „Stephen King“ geschrieben wurde. Die entsprechende Formel lautet:

=WENN(F2 = "Stephen King"; "Ja"; "Nein")
Mit WENN können Sie sowohl textuelle als auch numerische Werte überprüfen.

Verkettung der WENN-Funktion

Manchmal kann es der Fall sein, dass eine weitere Bedingung überprüft werden soll, nachdem die erste bestanden bzw. nicht bestanden wurde. In solchen Fällen kann anstelle eines „Dann-Werts“ bzw. „Sonst-Werts“ eine weitere WENN-DANN-Funktion angegeben werden. In folgendem Beispiel wird überprüft, ob Pakete schon versandt wurden.

=WENN(J3="Angekommen";"Ja";WENN(J3="In Zustellung"; "Ja";"Nein"))
Sie können die WENN-Funktion mit sich selbst verketten um zwischen mehrere Werte zu unterscheiden.
Hinweis

Bei mehreren verketteten Überprüfungen ist dieser Ansatz nicht empfehlenswert. Die Verschachtelungen führen zu einer Komplexität, bei der es schwer wird, eine fehlerfreie Syntax zu erstellen. In solchen Fällen ist es sinnvoll, auf eine andere Excel-Funktion wie zum Beispiel SVERWEIS oder WENNS auszuweichen.

Kombination mit weiteren Funktionen

Wie bei der Verkettung von WENN können auch andere Excel-Funktionen in den Feldern der WENN-Funktion eingesetzt werden. Funktionen, die als Bedingung der WENN-Funktion angegeben werden, müssen allerdings immer zu „Wahr“ oder „Falsch“ auswerten. Folgend wird das obige Beispiel mit der Excel-ODER-Funktion rekonstruiert.

=WENN(ODER(N2="Angekommen";N2="In Zustellung");"Ja";"Falsch")
Sie können auch andere Funktionen in den Eingabefeldern von WENN einsetzen.

Komplexeres Beispiel

Abschließend stellen wir ein etwas komplexeres Beispiel vor. In diesem Beispiel wird der Kurs einer Aktie verfolgt, und angegeben, ob es sich um einen Wertverlust oder eine Wertzunahme handelt. Der Betrag dieses Verlusts bzw. dieser Zunahme wird berechnet und auch angegeben. Dafür wird die Excel-VERKETTEN-Funktion eingesetzt.

=WENN(R3<R2;VERKETTEN("Verlust: "; R2-R3);VERKETTEN("Gewinn: "; R3-R2))
Mit WENN können Sie komplexe Operationen mit mehreren Funktionen und Zellbezügen durchführen.

WENNS: Erweiterung von Wenn-Dann

Wenn Sie Microsoft 365, Office 2021, Office 2019 oder Office Online nutzen, steht Ihnen noch eine andere Excel-Funktion zur Verfügung. Die WENNS-Funktion arbeitet ähnlich wie WENN: Einer logischen Prüfung wird ein Dann_Wert zugeordnet – allerdings bis zu 127-mal. Die Syntax lautet demnach:

=WENNS(Etwas ist Wahr1; Wert wenn Wahr1; [Etwas ist Wahr2; Wert wenn Wahr2];…[Etwas ist Wahr127; Wert wenn Wahr127])

Beispielsweise wäre es denkbar, für Produkte in einem Laden einen Rabatt zu gewähren, wenn sie schon länger nicht gekauft wurden. Dieses Beispiel könnte erweitert werden, indem der Preis von bereits vergünstigten Produkten noch weiter reduziert wird, wenn von diesen Produkten nur noch wenige Exemplare vorhanden sind. Damit hätten wir zwei Bedingungen: Der letzte Abverkauf ist schon über 30 Tage her und es befinden sich nicht mehr als 10 Exemplare im Lager. Deshalb müssen wir zum einen eine UND-Verknüpfung im ersten Prüfparameter unterbringen und zum anderen weitere Fälle definieren, denn wir möchten drei Ergebnisse möglich machen: 50 Prozent Rabatt, 25 Prozent Rabatt und kein Rabatt.

Was dabei auffällt: Es gibt keinen Sonst_Wert mehr. Das bedeutet aber auch, dass man den Umkehrschluss – also in unserem Beispiel den Fall, dass keine Rabatte zum Einsatz kommen – selbst definieren muss. Daher gilt:

=WENNS(UND(TAGE(HEUTE();F2)>30;E2<10);C2*0,5;TAGE(HEUTE();F2)>30;C2*0,75;TAGE(HEUTE();F2)<=30;C2)

Die beiden Prüfungen für die Rabatte kommen jeweils hintereinander. Anschließend folgt der Sonst-Fall: Alle Produkte, deren letzter Verkauf weniger oder gleich 30 Tage her ist.

Mit der erweiterten WENNS-Funktion bietet Excel Ihnen andere Möglichkeiten zum logischen Vergleich.
Microsoft 365 Business mit IONOS!

Neueste Office-Version und automatische Aktualisierungen für mehr Sicherheit und neue Funktionen, 24/7 Experten-Support und Premium-Setup-Service!

Vollständiges Office-Paket
OneDrive mit 1TB
Auf bis zu 5 Geräten installierbar
Page top