Excel: Das UNGLEICH-Zeichen an Beispielen erklärt

Ein UNGLEICH-Zeichen erstellen Sie in Excel, indem Sie den Größer- und Kleiner-Operator miteinander kombinieren: <>. UNGLEICH zählt dabei zu den sogenannten logischen Operatoren, die festgelegte Bedingungen auf ihre Wahrheitswerte überprüfen und eine präzise Analyse von Übereinstimmungen bzw. Nichtübereinstimmungen in großen Datenmengen ermöglichen. Erfahren Sie, wie Sie das UNGLEICH-Zeichen in Excel richtig einsetzen.

Wofür wird UNGLEICH in Excel eingesetzt?

Das UNGLEICH-Zeichen in seiner einfachsten Form stellt fest, ob Werte in zu vergleichenden Zellen einander entsprechen oder nicht. Je nach Argument lautet der Wahrheitswert am Ende WAHR oder FALSCH, wenn die gewünschten Bedingungen einander gleich oder ungleich sind. Separat wird das UNGLEICH-Zeichen in Excel allerdings kaum eingesetzt, denn erst in Kombination mit Funktionen (z. B. WENN, ODER) zeigt es seinen eigentlichen Nutzen. Im Kontext einer Funktion entscheidet es, was passieren soll, wenn eine Bedingung nicht zutrifft.

 

Das Excel-UNGLEICH-Zeichen – die Syntax erklärt

Die einfachste Anwendungsform des UNGLEICH-Zeichens ist eine Funktion aus zwei Bedingungen und dem UNGLEICH-Operator:

=(Bedingung1<>Bedingung2)

Exemplarisch nehmen wir als Bedingung 1 die Excel-Zelle A1 mit dem Wert 2 und als Bedingung 2 Zelle B1 mit dem Wert 3. Durch das UNGLEICH-Zeichen <> fragen wir nun, ob A1 „ungleich“ B1 ist, und erhalten als Ergebnis WAHR.

Natürlich lässt sich diese Abfrage auch für mehrere Zellen, Spalten und Werte gleichzeitig durchführen. Die Syntax erweitert sich entsprechend der Komplexität der zu untersuchenden Bedingungen:

=(Bedingung1<>Bedingung2<>Bedingung3)

Um mehrere aktive Zellen und Spalten in einem Projekt zu analysieren, ziehen Sie hierfür einfach das grüne Füllkästchen in der Spalte, die ihre gewünschten Ausgabewerte zeigen soll, bis zur letzten Zeile des betreffenden Bereichs.

Per Eingabetaste setzen Sie die Funktion anschließend in absoluten Bezug.

Prinzipiell ist die Anwendung des Zeichens also recht einfach. Kompliziert wird es, wenn das UNGLEICH-Zeichen in verschachtelten Argumenten und mit großen Datenmengen zum Einsatz kommt. Mit unseren Beispielen behalten Sie den Durchblick.

Das Excel-UNGLEICH-Zeichen in komplexe Funktionen einsetzen

Nachdem die Funktion des UNGLEICH-Zeichens geklärt ist, lernen Sie nun, das Zeichen effektiv durch Verschachtelung in andere Funktionen einzusetzen. Die Werte, die Excel-UNGLEICH ermittelt, können dabei helfen, eine Analyse z. B. innerhalb einer WENN-, ODER- oder NICHT-Funktion zu präzisieren.

Beispiel 1: Excel-UNGLEICH + WENN

Insbesondere die Kombination mit der WENN-Funktion zeigt die Vorteile des UNGLEICH-Zeichens auf. Sie werden schnell feststellen, dass es sich in Verbindung mit der WENN-Funktion kaum vom GLEICH-Zeichen unterscheidet und lediglich die genau entgegengesetzte Funktion erfüllt. Durch die Verbindung mit der WENN-Funktion fragen Sie nach bestimmten Bedingungen und bewirken, dass in einem bestimmten Fall (WENN) ein bestimmtes Resultat (DANN) folgt.

Als Beispiel könnte die WENN-Funktion prüfen, wer bei einem Gewinnspiel die Gewinnnummer 104 gezogen hat. In diesem Beispiel wären GLEICH und UNGLEICH äquivalent.

=Wenn(B3=104,"Gewinn","Nichtgewinn")

Die WENN-Funktion gibt also vor: WENN die Losnummer aus Zelle B3 identisch mit der Gewinnnummer 104 ist, dann erhalten Sie „Gewinn“ als Ausgabewert. Wenn nicht, erhalten Sie die Aussage „Nichtgewinn“. Mit dem Ausfüllkästchen wenden Sie die Funktion wieder automatisch auf alle betreffenden Zellen an.

Hinweis

Achten Sie darauf, dass Texteingaben in einer Funktion immer in doppelten Anführungszeichen stehen müssen.

Mit dem Excel-UNGLEICH-Zeichen sähe die Funktion nahezu identisch aus. Sie ersetzen lediglich das GLEICH-Zeichen durch das UNGLEICH-Zeichen und tauschen die Position von „Gewinn“ und „Nichtgewinn“ in der Formel:

=Wenn(B3<>104, "Nichtgewinn","Gewinn")

Der Einsatz des GLEICH- oder UNGLEICH-Zeichens führt zu nahezu identischen Werten, wobei die Ergebnisse genau entgegengesetzt sind. Machen Sie den Einsatz der Operatoren einfach von den gewünschten Resultaten abhängig.

Beispiel 2: Excel-UNGLEICH + WENN + ODER

Excel gibt Ihnen beinahe unendlich viele Möglichkeiten an die Hand, komplexe und verschachtelte Argumente in logischen Funktionen zu untersuchen. Sie können z. B. das UNGLEICH-Zeichen in eine Kombination der WENN- und der ODER-Funktion einbauen, um so zu Ihren gewünschten Ausgabewerten zu kommen.

Tipp

Eine Kombination der WENN-Funktion mit anderen Excel-Funktionen erhöht die Präzision Ihrer Analysen. Die Kombination von Excel-WENN- und ODER-Funktion ist dabei besonders nützlich.

In Syntax-Form sieht eine mögliche Funktion, die UNGLEICH, WENN und ODER kombiniert, am oben genannten Beispiel eines Gewinnspiels so aus:

=WENN(ODER(B3<>1;C3<>0;D3<>4);"Nichtgewinn";"Gewinn"))

In diesem Beispiel müssen drei richtige Zahlen angekreuzt sein, um zu gewinnen. Wenn die zutreffende Bedingung auftritt, soll „Nichtgewinn“ folgen, andernfalls „Gewinn“.

Im konkreten Beispiel des Gewinnspiels sieht es so aus:

Beispiel 3: UNGLEICH + SUMMEWENN-Funktion

Auch in Verbindung mit der mathematischen Excel-Funktion SUMMEWENN ist das UNGLEICH-Zeichen von Nutzen. SUMMEWENN ermittelt nicht nur die Summe der Werte Ihrer Tabelle oder Spalte, sondern kann die Summe ganz spezifischer Zahlen in ihrer Kalkulation ermitteln. Im folgenden Beispiel soll SUMMEWENN nur die Werte von Zellen zusammenzählen, wenn die Nachbarzellen nicht leer sind, also in diesem Fall die Werte UNGLEICH „“ (leer) sind.

=SUMMEWENN(C3:C6,"<>"&"",B3:B6)

Die Funktion soll hier die Werte von Zelle B3 bis B6 und C3 bis C6 vergleichen und eventuell zusammenzählen. Der Doppelpunkt dient als Begrenzung der Zellen, für die eine Summe gewünscht ist. Nur Zellen, die nicht bzw. UNGLEICH leer („“) sind, sollen in die Summe miteinbezogen werden.

Wie gewünscht, erhalten Sie mit Einsatz des UNGLEICH-Zeichens somit nur die Summe der Zellen, die Sie haben wollten.


Auf dem Laufenden bleiben?

Jetzt für unseren Newsletter anmelden und gratis Online-Marketing Whitepaper für lokale Anbieter sichern!