Excel: WENN-ODER-Formel einfach erklärt

Die meisten Microsoft-Nutzer, die mit der Tabellenkalkulation Excel arbeiten, kennen und verwenden bereits die beliebte WENN-Funktion. Mit dieser erstellen Sie auf einfache Weise Abfragen, indem Sie eine oder mehrere Bedingungen gleichzeitig festlegen, um ein bestimmtes Ergebnis zu erhalten. Kombinieren Sie die WENN- mit der ODER-Funktion, wird auch dann ein Ergebnis ausgeworfen, wenn nur eine der festgelegten Bedingungen wahr ist. Wie dies in der Praxis aussieht, erläutern wir hier anhand einfacher Beispiele.

Tipp zu: Office-Dokumente verwalten

Mit dem IONOS HiDrive Cloud-Speicher speichern, bearbeiten und teilen Sie Ihre Office-Dokumente zentral und sicher. Ob privat oder beruflich: Arbeiten Sie flexibel von jedem Gerät aus mit der HiDrive-App und anderen Schnittstellen. In den hochmodernen deutschen Rechenzentren von IONOS sind Ihre Daten bestens geschützt.

Was ist die WENN-ODER-Funktion?

Die Excel-WENN-ODER-Funktion ist eine Erweiterung der WENN-Funktion, die auch als WENN-DANN-Funktion bekannt ist. Durch ihre vielfältigen Anwendungsmöglichkeiten gehört sie zu den wichtigsten Funktionen in Excel. Mit ihr fragen Sie ab, ob ein bestimmter Wert mit einem erwarteten Wert übereinstimmt. Sind die Werte identisch, tritt ein vordefinierter Fall ein. Stellt sich der Vergleich als falsch heraus, wird eine andere Aktion ausgelöst. Die Voraussetzungen, die bestimmen, ob ein Ergebnis wahr oder falsch ist, legen Sie zuvor fest.

Kombinieren Sie die WENN-Funktion nun mit der ODER-Funktion, haben Sie die Möglichkeit, mehrere Bedingungen aufzustellen. Mindestens eine davon muss zutreffen, damit Excel das Ergebnis als wahr auswirft. Ist entweder die Bedingung A oder die Bedingung B wahr, tritt Zustand C ein. Werden beide Bedingungen nicht erfüllt, tritt Zustand D ein. In ihrer Struktur sieht die Formel wie folgt aus:

=WENN(ODER(etwas ist WAHR;etwas anderes ist WAHR);Dann_Wert;Sonst_Wert) 

In der obigen Formel ist das Element „etwas ist WAHR“ die Bedingung A und „etwas anderes ist WAHR“ die Bedingung B. Demnach entspricht der „Dann_Wert“ dem Zustand C und der „Sonst_Wert“ dem Zustand D.

Hinweis

Als Alternative zur WENN-ODER-Funktion gibt es die WENN-UND-Funktion. Bei dieser müssen beide Bedingungen A und B wahr sein, damit Zustand C eintritt. Die ebenfalls verwandte WENN-NICHT-Funktion akzeptiert hingegen immer nur eine einzige Bedingung.

Excel-WENN-ODER: Praktisches Beispiel für die Funktionskombination

In der nachfolgenden Beispieltabelle sind in Spalte A die potenziellen Teilnehmer eines Schulungsprogramms aufgelistet. Um von der Bildungsinstitution aufgenommen zu werden, müssen die Personen entweder einen Grundkurs besucht oder den Aufnahmetest mit mindestens 600 Punkten bestanden haben:

Da die Bedingungen feststehen, können Sie im nächsten Schritt die Formel ausarbeiten. Markieren Sie zunächst die Zelle D2. Dort soll die Frage nach der Aufnahme mit „JA“ oder „NEIN“ beantwortet werden. Der Zustand „JA“ tritt ein, wenn ein Teilnehmer den Grundkurs absolviert hat (Wert „besucht“ in Spalte B) oder in Spalte C mehr als 600 Punkte vorweisen kann. Die Antwort „NEIN“ wird ausgeworfen, wenn keine der beiden Bedingungen erfüllt ist. Geben Sie nun in der Bearbeitungsleiste die folgende Formel ein:

=WENN(ODER(B2="besucht";C2>599);"JA";"NEIN")

Nachdem Sie die Formel mit der Eingabetaste bestätigt haben, zeigt Excel in D2 das entsprechende Ergebnis an:

Um die Zeilen 3 bis 6 in Spalte D ebenfalls mit den entsprechenden Ergebnissen zu füllen, müssen Sie die Funktion nicht jedes Mal neu einfügen. Markieren Sie einfach die Zelle D2 und ziehen Sie den grünen Rahmen bis in die letzte Zeile. Da die Formel einen relativen Bezug ausdrückt, werden B2 und C2 automatisch zu B3 und C3 etc.:

Die WENN-ODER-Funktion kombinieren

Die Excel-WENN-ODER-Funktion hat den Vorteil, dass Sie sich mit anderen nützlichen Funktionen kombinieren lässt. Dies erlaubt Ihnen, komplexere Abfragen zu starten. Im Folgenden sehen Sie die Tabelle des vorherigen Beispiels. Diesmal sind Vor- und Nachnamen der potenziellen Teilnehmer in den Spalten A und B angegeben:

In der Spalte E möchten Sie nun nicht nur die Antworten „JA“ oder „NEIN“ erhalten, sondern den vollständigen Satz „[Vorname] [Nachname] wird aufgenommen“ oder „[Vorname] [Nachname] wird nicht aufgenommen“. Dies erreichen Sie, indem Sie die VERKETTEN-Funktion in die WENN-ODER-Funktion integrieren. Markieren Sie zunächst den Zellenbereich E2 bis E6. Tragen Sie nun die folgende Formel in die Bearbeitungsleiste ein:

=VERKETTEN(A2;" ";B2; " ";WENN(ODER(C2="besucht";D2>599);"wird aufgenommen";"wird nicht aufgenommen"))

Der erste Teil der Formel verkettet die Inhalte der Zellen A und B. Damit im Ergebnis die einzelnen Textelemente nicht direkt aneinandergereiht werden, setzen Sie nach A2 und B2 jeweils zwei Anführungszeichen, die ein Leerzeichen umschließen. Danach folgt die WENN-ODER-Funktion, die den Satz mit dem jeweiligen Ergebnis vervollständigt.

Je nach Bedarf lässt sich die WENN-ODER-Funktion in Excel mit den verschiedensten Funktionen kombinieren. Achten Sie jedoch immer darauf, dass bei verschachtelten Formeln die korrekte Anzahl an Klammern vorhanden ist. Wird eine Klammer nicht geschlossen, erscheint eine Fehlermeldung. Um solche Fehler zu umgehen, nutzen Sie einfach den Formel-Generator über den Menüpunkt „Funktion eingeben“, der automatisch die richtige Syntax herstellt.

HiDrive Cloud Speicher von IONOS

Daten zentral speichern, teilen und bearbeiten. Flexibel von jedem Gerät aus. Datenverlust unmöglich: Rechenzentrum in Deutschland, ISO-Zertifizierung und DSGVO.

Überall verfügbar
Gemeinsamer Zugriff
Hochsicher

Auf dem Laufenden bleiben?

Jetzt für unseren Newsletter anmelden und gratis Online-Marketing Whitepaper für lokale Anbieter sichern!